Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi?
#11
THank you very much for this code!

Just to let you know, i think you have a typo in the code section above

Code:
/etc/init.d/S13fbcp start


i have managed to do this by launching manually with:
Code:
sudo /etc/init.d/fbcp.sh start



I could not find the 'original' Kodi.sh on RetroPie, so i created Kodi as a 'system' using the tips here: https://github.com/RetroPie/RetroPie-Setup/wiki/KODI

I added the above after running
Code:
sudo nano /home/pi/RetroPie/roms/kodi/kodi.sh

and the new code was (as stated by Flavor), but i had to add a 'sudo'


Code:
sudo service fbcp stop

sudo /home/pi/Freeplay/startfbcp.sh & kodi-standalone

This now works great for booting.

if i 'pkill kodi' manually, then there is no issue with the screen, but using Kodi's own exit routine the same problem crops up, so the script needs running on Kodi exit too.

It must be possible to fix this though....  since there is a complex script for kodi you can find here;
Code:
sudo nano /usr/bin/kodi

However, despite a few attempts inserting the new script at the end, i could not get it to re-display the Emulation Station screen. Interestingly once this happens as well i cannot get it to 'manually' switch back on either.
Reply
#12
Nice work, HoraceAndTheSpider. You are right about the typos. I was going off of the Recalbox stuff I had been playing with, and it is not the same for RetroPie. Thanks for the help posting that info. I don't know about the shutdown stuff. Is your Kodi set to run at a different resolution than what is set up in your config.txt file? Then it might try to switch back when you exit.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#13
so the CM3 default in config.txt is


Code:
framebuffer_width=320
framebuffer_height=240


I am sure it is not possible to select this mode from Kodi inside (there is a 'desktop' option though, but this is causing a crash for me atm - i will have to try changing to this with the HDMI plugged in)

I changed the following:
Code:
sudo nano /home/pi/.kodi/userdata/guisettings.xml


so that under <videoscreen> the following was applied:
Code:
<screenmode>00064000480060.00000pstd</screenmode>

unfortunately on loading Kodi it resets itself to 640x480 and still quitting is not possible.

There used to be a similar bug on regular retropie setups , and i am wondering if that is kicking in again, since it is no possible to 'restore' the Emulation Station screen even if restarting fbcp
Reply
#14
You can change the settings in the config.txt. It’s worth trying anyway.
Card Fighters' Clash 2 English Translation ( http://cfc2english.blogspot.com/ )
Neo Geo Pocket Flash Cart and Linker Project ( http://www.flashmasta.com/ )
Avatar art thanks to Trev-Mun ( http://trevmun.deviantart.com/ )
Reply
#15
Thank you for the efforts so far on this. Could anyone help me out with a quick tutorial on getting kodi to work on the freeplay zero?

Is this the correct location and command to run in order to change what I need to on the zero?

Code: "sudo nano /home/pi/RetroPie/roms/kodi/kodi.sh"

and then I need to add the following?

Code: "sudo /etc/init.d/fbcp.sh start"

any help is appreciated, Thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)